Author Topic: Clamp issue with earth textures  (Read 357 times)

Adehlin

  • Newbie
  • *
  • Posts: 30
    • View Profile
Clamp issue with earth textures
« on: February 23, 2019, 01:41:40 PM »
Hello!

In the Unity editor as well as on a Samsung Galaxy 9 it's all looking fine. But on another high-end ARM device (using Android 9) as well on a Huawei MediaPad tablet I do see the 4 earth textures (used in 16k Natural Scenic Scatter) aren't being wrapped in a nice way. As you can see on below image, there's a not-so-good-looking jagged white edge between the textures.
https://imgur.com/3r4KpYj

I'm using the default Import Settings (i.e. Wrap Mode = Clamp).
https://imgur.com/qkAKfMg

Any idea how this can be fixed?

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4887
    • View Profile
Re: Clamp issue with earth textures
« Reply #1 on: February 24, 2019, 04:40:20 AM »
Probably has to do with mip-maps bilinear artifacts around the edges. Try latest beta which uses a fixed mip-map level.

Adehlin

  • Newbie
  • *
  • Posts: 30
    • View Profile
Re: Clamp issue with earth textures
« Reply #2 on: February 24, 2019, 01:51:15 PM »
I've tested the beta on the tablet and I can confirm it does fix the issue. No artifacts around the edges any longer.

Excellent and thank you very much once again!

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4887
    • View Profile
Re: Clamp issue with earth textures
« Reply #3 on: February 24, 2019, 02:14:00 PM »
Great, thanks for the confirmation.