Author Topic: Issue with left eye camera on Vive Focus Plus  (Read 220 times)

Aymeric

  • Guest
Issue with left eye camera on Vive Focus Plus
« on: March 25, 2020, 07:23:29 AM »
Hello,

I use Wave SDK 3.1.8 and Unity 2019.2.21f1 with VIU plugin https://assetstore.unity.com/packages/tools/integration/vive-input-utility-64219.

It works fine with my right eye, but on the left eye it seems it grabs the head camera and not the left eye. How to fix that?

Thanks

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 5706
    • View Profile
Re: Issue with left eye camera on Vive Focus Plus
« Reply #1 on: March 25, 2020, 08:01:20 AM »
Can you post your settings? Have you tried using Fast or High quality settings for outline/glow instead of Highest?

Aymeric

  • Guest
Re: Issue with left eye camera on Vive Focus Plus
« Reply #2 on: March 25, 2020, 08:10:01 AM »
Thank you for the quick answer. Please note that with the left eye, when I move my head the outline moves also, whereas it should stay with the object.

This is my settings:

Aymeric

  • Guest

Aymeric

  • Guest
Re: Issue with left eye camera on Vive Focus Plus
« Reply #4 on: March 26, 2020, 06:02:59 AM »
Hi Kronnect, any update on this?

Best,
Aymeric

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 5706
    • View Profile
Re: Issue with left eye camera on Vive Focus Plus
« Reply #5 on: March 26, 2020, 07:13:09 AM »
Will try to check this today.

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 5706
    • View Profile
Re: Issue with left eye camera on Vive Focus Plus
« Reply #6 on: March 26, 2020, 01:01:10 PM »
Hi,

We have tested latest version of the asset again with Oculus Quest (we don't own a Vive set) in Multi-Pass, Multi-View and Single Pass Stereo modes and it worked perfectly using your exact settings.
The settings you're using are very safe and should work out of the box.
Unfortunately I'm not sure what could be the issue - it could be a SDK issue.
Have you tried using Multi-Pass rendering?

Aymeric

  • Guest
Re: Issue with left eye camera on Vive Focus Plus
« Reply #7 on: March 27, 2020, 03:26:07 AM »
Hello,

Thanks for your message: I tried several stereo rendering mode and the problem is only with Multiview. Switching to Multi Pass or Single Pass works fine :D

Thanks again for the support!