Author Topic: Snow showing as black on build  (Read 1248 times)

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #15 on: February 18, 2019, 04:33:45 PM »
Try disabling static/dynamic batching in Player Settings (just to test if this is the reason).

Cronos

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Snow showing as black on build
« Reply #16 on: February 18, 2019, 05:57:08 PM »
I disabled both Static and Dynamic Batching on Player Settings, but the build had the black snow still.

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #17 on: February 19, 2019, 12:08:42 AM »
Could you please try to create a simple repro scene and send it to me?

Cronos

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Snow showing as black on build
« Reply #18 on: February 19, 2019, 03:18:25 PM »
Hey Kronnect, I think I found out. It's the "Graphics Jobs (Experimental)" on Player Settings. It was turned on for me. I turned it off and snow is back in white. Do you know what is it and how is it related to Global Snow? I read somewhere it's related to job threads to directly create DX12 command buffers.

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #19 on: February 19, 2019, 03:29:14 PM »
Don't know how it can relate to this issue, probably some kind of bug since that feature has been quite stall for years.
Here you have some info: https://unity3d.com/learn/tutorials/topics/best-practices/multithreaded-rendering-graphics-jobs

Cronos

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Snow showing as black on build
« Reply #20 on: February 21, 2019, 06:30:50 AM »
Anything that we can do on Global Snow side to prevent this issue to happen with Graphic Jobs on? It seems to use Multi-threading, which could be good for performance.

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #21 on: February 22, 2019, 03:07:47 AM »
I've tried to reproduce the issue without any luck using the included demo scenes. Any chance you can send me a simple repro scene?

Cronos

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Snow showing as black on build
« Reply #22 on: February 24, 2019, 06:59:37 PM »
Hi Kronnect,

Using Unity 2018.3.5f1 I made a build with only the latest Global Snow package on Asset Store adding only the SnowScene_Deferred.unity on Build Settings. I also turned on the "Graphics Jobs (Experimental)" checkbox on Player Settings. Then running the build I was able to see the issue. I attached a screenshot here.  Let me know if I can help you with any more details to repro it. Thank you

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #23 on: February 25, 2019, 03:58:58 AM »
Thank you, I've reproduced the issue and submitted a bug report to Unity.

The following workaround seems to work: in Global Snow inspector, set "Deferred Camera Event" to "Before Lighting".

Regards.
« Last Edit: February 25, 2019, 04:06:03 AM by Kronnect »

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4743
    • View Profile
Re: Snow showing as black on build
« Reply #24 on: March 25, 2019, 08:23:27 AM »
Hi again,

Just got a reply from Unity QA regarding this issue:

"Thank you for reporting the issue. We have fixed this problem and it should not appear in Unity latest 2019.1.0b9, 2019.2.0a10 and above."

I hope they port back the fix to 2018.x but they have not confirmed it.

Regards