Author Topic: Error after update 10.0  (Read 168 times)

sanderhof

  • Newbie
  • *
  • Posts: 22
    • View Profile
Error after update 10.0
« on: June 30, 2019, 02:23:13 AM »
Hi,

After updating to the latest version, I'm getting the following error below. Nothing else was changed in my setup and it was working perfectly before. Any thoughts on why this is happening and how I can fix this?

Code
ArgumentException: The Object you want to instantiate is null.
UnityEngine.Object.CheckNullArgument (System.Object arg, System.String message) (at C:/buildslave/unity/build/Runtime/Export/Scripting/UnityEngineObject.bindings.cs:374)
UnityEngine.Object.Instantiate[T] (T original) (at C:/buildslave/unity/build/Runtime/Export/Scripting/UnityEngineObject.bindings.cs:265)
TGS.TerrainGridSystem.Init () (at Assets/TerrainGridSystem/Scripts/Core/TGSPrivate.cs:467)
TGS_Editor.TGSInspector.OnEnable () (at Assets/TerrainGridSystem/Editor/TGSInspector.cs:48)
TGS_Editor.TGSInspector.OnInspectorGUI () (at Assets/TerrainGridSystem/Editor/TGSInspector.cs:571)
UnityEditor.UIElements.InspectorElement+<CreateIMGUIInspectorFromEditor>c__AnonStorey1.<>m__0 () (at C:/buildslave/unity/build/Editor/Mono/Inspector/InspectorElement.cs:462)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Kind regards,
Sander

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4994
    • View Profile
Re: Error after update 10.0
« Reply #1 on: June 30, 2019, 02:49:45 AM »
Hi,
Some material names have changed. Please remove the asset and reimport it again. That should fix the issue.
This issue will be prevented in next update.
Thanks.

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 4994
    • View Profile
Re: Error after update 10.0
« Reply #2 on: June 30, 2019, 03:55:31 AM »
Fixed in v10.0.1.