Author Topic: Completely Stop Earth Rotation  (Read 36 times)

Fierde

  • Guest
Completely Stop Earth Rotation
« on: July 10, 2019, 01:51:57 PM »
Hey guys,

This feels like it should be an obvious solution, but I'm having trouble getting the Earth to stop rotating when I spin around. I've set up my own custom camera to move around the globe, and turned off "Allow User Rotation" in the Interaction Settings Menu. I've made sure all of WorldMapGlobe's rigidbody constraints are frozen. I've set Mode to "Camera Moves" and not "Earth Moves" The only thing that should be moving is the camera, yet when I try to navigate the camera by clicking and dragging (as is set up in my camera class), the WorldMapGlobe Object still rotates sometimes. Any ideas why, or how to disable it?

Fierde

  • Guest
Re: Completely Stop Earth Rotation
« Reply #1 on: July 11, 2019, 06:27:31 AM »
Nevermind, i just had to manually freeze WorldMapGlobe's rotation in my camera class.